Problemi con la MiniMaus? - Risolti i miei!

L'angolo degli smanettoni .Discussioni inerenti lo sviluppo di nuovi progetti DCC o l'hack di sistemi commerciali.

Moderatori: Luca.Rubini, Seba55

Messaggio
Autore
Avatar utente
experimentator
PlasticoDigitale
Messaggi: 259
Iscritto il: domenica 24 febbraio 2008, 12:21
Scala: N H0
Ho il plastico: Si
La mia centrale digitale.: Roco+Lokmaus2+Minimaus autocostruito+NanoX autocostruita
Località: Trieste

Problemi con la MiniMaus? - Risolti i miei!

#1 Messaggioda experimentator » mercoledì 30 gennaio 2013, 18:45

Avevo costruito NanoX e Minimaus ma per mancanza di tempo (e problemi familiari molto pesanti... :( ) non l'avevo mai messa in funzione. Ora ho comprato dei decoder Lenz, per ora quelli economici, poi saranno sostituiti dagli ESU e trovato una centralina Roco con Lokmaus2. I decoder (per ora provati con un motore di ricambio ciascuno e attaccati cinofallicamente) hanno funzionato con questa, quindi va tutto bene col "Lokgiocattolo".
Quando ho collegato alla centralina Roco la Minimaus... non va.
Volevo provare a gestire due decoder assieme ma separatamente, anche se in modo "fittizio".
Ho collegato la Minimaus in "slave" alla centralina Roco, nella NanoX manca il trasformatore (anche se forse si può usare quello Roco?), finito "recuperato" poco tempo dopo l'allestimento.
Qualcuno ha avuto problemi simili?
Ho letto tempo fa che la Minimaus a diversi non è andata: cosa succedeva?
A me si comporta come se la tastiera non esistesse. Il visore indica sempre il menu: prima appare il "benvenuto" ma poi appare il menu e si blocca tutto. :grrr:
Ancora più assurdo: se stacco un filo (A o B), indica che la centrale non è collegata! :doh:
A scanso di equivoci: la tastiera funzia ed è collegata correttamente.
Paulus Tergestinus Experimentator

Avatar utente
experimentator
PlasticoDigitale
Messaggi: 259
Iscritto il: domenica 24 febbraio 2008, 12:21
Scala: N H0
Ho il plastico: Si
La mia centrale digitale.: Roco+Lokmaus2+Minimaus autocostruito+NanoX autocostruita
Località: Trieste

Re: Problemi con la MiniMaus? - Risolti i miei!

#2 Messaggioda experimentator » giovedì 31 gennaio 2013, 15:35

Problemi appena risolti. :yehaa:
A parte il macroscopico errore che una resistenza di forzamento della tastiera (mavvà ?) mancava, erano 3 e dovevano esser 4 e manca sullo schema :shock: , c'era un problema insito nel mio circuito stampato, derivato da quello di Paco ma per motivi di incisione non identico. Il problema erano due piste concentriche che formavano probabilmente un "loop" captando disturbi. Ho collegato le resistenze della tastiera (con la quarta!) ad una pista dei +5V più distante, quasi sul 7805, e su quelle due ravvicinate ho aggiunto un condensatore da 100 nF: pochi centesimi e i problemi sono spariti. La difficoltà  maggiore è stata ovviamente fare il cablaggio "semivolante" delle quattro resistenze, non particolarmente difficoltoso se non fosse stato per lo scarso spazio. :?
Ho anche reso variabile il contrasto del visore (quello che ho trovato è sì "pin-to-pin" ma "bianco su nero", non "nero su verde"), con una manopola come sui vecchi TV... :mrgreen:
Ora vedo di "reinscatolarlo", se il potenziometro supplementare ci sta... :roll:

Ohi, pensavo di aver buttato nel cesso quasi 30 anni di esperienza di elettronica sperimentale... :ops:
Paulus Tergestinus Experimentator

Avatar utente
r302
PlasticoDigitale
Messaggi: 485
Iscritto il: sabato 2 luglio 2005, 19:30
Scala: H0
Ho il plastico: Si
La mia centrale digitale.: JMRI + Kdccx - XnTcp per iBookG4 - Lokmaus2 Simplemaus e iPhone in WiFi
Località: Sicilia
Contatta:

Re: Problemi con la MiniMaus? - Risolti i miei!

#3 Messaggioda r302 » giovedì 31 gennaio 2013, 17:28

experimentator ha scritto:Problemi appena risolti. :yehaa:
A parte il macroscopico errore che una resistenza di forzamento della tastiera (mavvà ?) mancava, erano 3 e dovevano esser 4 e manca sullo schema :shock: , c'era un problema insito nel mio circuito stampato, derivato da quello di Paco ma per motivi di incisione non identico. Il problema erano due piste concentriche che formavano probabilmente un "loop" captando disturbi. Ho collegato le resistenze della tastiera (con la quarta!) ad una pista dei +5V più distante, quasi sul 7805, e su quelle due ravvicinate ho aggiunto un condensatore da 100 nF: pochi centesimi e i problemi sono spariti. La difficoltà  maggiore è stata ovviamente fare il cablaggio "semivolante" delle quattro resistenze, non particolarmente difficoltoso se non fosse stato per lo scarso spazio. :?
Ho anche reso variabile il contrasto del visore (quello che ho trovato è sì "pin-to-pin" ma "bianco su nero", non "nero su verde"), con una manopola come sui vecchi TV... :mrgreen:
Ora vedo di "reinscatolarlo", se il potenziometro supplementare ci sta... :roll:

Ohi, pensavo di aver buttato nel cesso quasi 30 anni di esperienza di elettronica sperimentale... :ops:


Scusa, visto che hai risolto i problema del minimaus potresti allegare schema delle modifiche? Cos'è sta storia che c'è una quarta reistenza che manca sulla schema?
Grazie comunque
r302
centrale Kdccx con il suo booster - interfaccia XnTcp per iBookG4 - palmari Multimaus, Lokmaus2, Simplemaus (in costruzione) e iPhone in WiFi (se riesco a farlo funzionare!) - software JMRI

http://www.aulino.it/aulinodecals/Aulin ... ecals.html

Avatar utente
experimentator
PlasticoDigitale
Messaggi: 259
Iscritto il: domenica 24 febbraio 2008, 12:21
Scala: N H0
Ho il plastico: Si
La mia centrale digitale.: Roco+Lokmaus2+Minimaus autocostruito+NanoX autocostruita
Località: Trieste

Re: Problemi con la MiniMaus? - Risolti i miei!

#4 Messaggioda experimentator » giovedì 31 gennaio 2013, 22:41

r302 ha scritto:Scusa, visto che hai risolto i problema del minimaus potresti allegare schema delle modifiche? Cos'è sta storia che c'è una quarta reistenza che manca sulla schema?
Grazie comunque

Prendi lo schema dal sito di Paco. Guarda bene dove è raffigurato il connettore della tastiera (KEYB 4x4): il conduttore denominato COL4 è disegnato direttamente collegato solo al terminale 6 del PIC. Manca una resistenza che, come le altre tre "colonne" della tastiera, lo "forzi" a +5V.
Bisogna aggiungerne una (sempre 10K) fra piedino 6 del PIC e i +5V, es. piedino 14 (così si può fare sotto lo stampato).

Poi per il visore, se hai quello "bianco su nero" (io l'ho preso da Futura Elettronica), ti conviene sostituire le resistenze R1 (indicata 330R) e R2 (indicata 10K) con un potenziometro lineare da 10K collegato fra i +5V e la massa e col cursore collegato dove R1 e R2 (che vanno tolte) si congiungono.
Io, avendo il visore "cablato" e fissato al pannello del mobile anzichè sullo stampato, sono andato più sul semplice e ho collegato al piedino 3 del visore il cursore del potenziometro, ai piedini 1 e 2 gli estremi del potenziometro stesso. Poi bisogna trovare un posto dove fissare il potenziometro stesso. Col potenziometro il contrasto del visore te lo regoli tu a seconda della luce che hai nella stanza.
Nello schema di Paco mancano anche i due terminali della retroilluminazione del visore (che forse nel suo non c'era): se ce l'hai come il mio, dei due terminali, il K (sul mio è il piedino 16) va collegato a massa (sul piedino 1 dello stesso visore) e l'altro (il 15), denominato A, ai +5V (il piedino 2 del visore) ma interponendo una resistenza da fra 220 e 600 ohm, io usato una da 560.
Può essere che "pare non funzioni" perchè non è alimentata la retroilluminazione!
Il mio visore è un Xiamen Ocular, mod. GDM1602K: a parte la questione retroilluminazione, è compatibile pin-to-pin con quello di Paco. Il datasheet lo scarichi dal sito di Futura Elettronica (adesso il sito è però fuori servizio):
Paulus Tergestinus Experimentator

Avatar utente
r302
PlasticoDigitale
Messaggi: 485
Iscritto il: sabato 2 luglio 2005, 19:30
Scala: H0
Ho il plastico: Si
La mia centrale digitale.: JMRI + Kdccx - XnTcp per iBookG4 - Lokmaus2 Simplemaus e iPhone in WiFi
Località: Sicilia
Contatta:

Re: Problemi con la MiniMaus? - Risolti i miei!

#5 Messaggioda r302 » venerdì 1 febbraio 2013, 9:43

Ok, grazie per le dritte, ora ci rimetto mano. Il mio visore l'ho preso sulla baia a due lire e ha la lampada per l'illuminazione. La tastiera me la sono cablata io non avendo e trovata una. Una domanda: ma se sa tastiera il mini funziona lo stesso? Ossia, posto che non si possano dare comandi, almeno accende?
Comunque grazie.
r302
centrale Kdccx con il suo booster - interfaccia XnTcp per iBookG4 - palmari Multimaus, Lokmaus2, Simplemaus (in costruzione) e iPhone in WiFi (se riesco a farlo funzionare!) - software JMRI

http://www.aulino.it/aulinodecals/Aulin ... ecals.html

Avatar utente
experimentator
PlasticoDigitale
Messaggi: 259
Iscritto il: domenica 24 febbraio 2008, 12:21
Scala: N H0
Ho il plastico: Si
La mia centrale digitale.: Roco+Lokmaus2+Minimaus autocostruito+NanoX autocostruita
Località: Trieste

Re: Problemi con la MiniMaus? - Risolti i miei!

#6 Messaggioda experimentator » venerdì 1 febbraio 2013, 15:56

r302 ha scritto:Ok, grazie per le dritte, ora ci rimetto mano. Il mio visore l'ho preso sulla baia a due lire e ha la lampada per l'illuminazione. La tastiera me la sono cablata io non avendo e trovata una. Una domanda: ma se sa tastiera il mini funziona lo stesso? Ossia, posto che non si possano dare comandi, almeno accende?
Comunque grazie.

Nel mio (ma ho usato la tastiera completa), si rifiutava di andare finchè non ho collegato anche la IV resistenza e spostato il "comune" positivo delle resistenze via da quellla "spira chiusa" che c'è solo nel mio circuito. Il visore andava subito, solo era difficile vederci, poi ho risolto il problema del contrasto.
Se l'hai trovato sulla baya, attento che forse il visore non è compatibile pin-to-pin.
Quello di Futura Elettronica che va è questo, costa 15 euro.
questo, invece il datasheet.
Forse il visore indicato da Paco potrebbe essere questo: ha 14 piedini e la retroilluminazione separata. Costa la metà  del mio.

Se la tastiera te la sei fatta da solo, a maggior ragione dovrebbe funzionare.
Paulus Tergestinus Experimentator

amario
PlasticoDigitale
Messaggi: 393
Iscritto il: sabato 20 novembre 2004, 15:30
Scala: H0
Ho il plastico: Si
La mia centrale digitale.: Nanox_S88 Minimaus Simplemaus Xwl GenLi BoosterCDE Lokmaus2CDE Lokmaus
Località: Valle Seriana
Contatta:

Re: Problemi con la MiniMaus? - Risolti i miei!

#7 Messaggioda amario » lunedì 11 febbraio 2013, 20:30

Avete visto gli ultimi aggiornamenti della nanox e del minimaus sostituendo il pic originale con PIC16F648A.
http://usuaris.tinet.cat/fmco/whatsupdoc_en.html
Io ho fatto gli aggiornamenti e funziona tutto senza problemi, ho aggiunto il potenziometro al minimaus.
Provare per credere :wink:

Avatar utente
experimentator
PlasticoDigitale
Messaggi: 259
Iscritto il: domenica 24 febbraio 2008, 12:21
Scala: N H0
Ho il plastico: Si
La mia centrale digitale.: Roco+Lokmaus2+Minimaus autocostruito+NanoX autocostruita
Località: Trieste

Re: Problemi con la MiniMaus? - Risolti i miei!

#8 Messaggioda experimentator » lunedì 11 febbraio 2013, 21:42

amario ha scritto:Avete visto gli ultimi aggiornamenti della nanox e del minimaus sostituendo il pic originale con PIC16F648A.
http://usuaris.tinet.cat/fmco/whatsupdoc_en.html
Io ho fatto gli aggiornamenti e funziona tutto senza problemi, ho aggiunto il potenziometro al minimaus.
Provare per credere :wink:

Ci credo... senza provare :wink: :mrgreen:
Al di là  che non vado a smontarla di nuovo, il buco del potenziometro è occupato da quello di controllo del contrasto del visore e con le sfinestrature di tastiera e visore non è impossibile che con ulteriori sollecitazioni il pannello del mobile (alluminio da 1,2) possa spezzarsi.
Inoltre a me quel comando interessa per il controllo degli scambi.
Ciliegina sulla torta: avendo costruito fin troppi regolatori a "zero centrale" con qualcosa "a zero laterale" potrei trovarmi disorientato.

Ma sul piedino 6 del PIC manca sempre la resistenza che lo forza a +5V. :? Confrontate con i vecchi, l'errore resta. Se quella manca, la colonna 4 della tastiera non risponde.

Parziale OT: qualcuno ha costruito un controller amatoriale con manopola "a zero centrale"?
Paulus Tergestinus Experimentator

Avatar utente
experimentator
PlasticoDigitale
Messaggi: 259
Iscritto il: domenica 24 febbraio 2008, 12:21
Scala: N H0
Ho il plastico: Si
La mia centrale digitale.: Roco+Lokmaus2+Minimaus autocostruito+NanoX autocostruita
Località: Trieste

Re: Problemi con la MiniMaus? - Risolti i miei!

#9 Messaggioda experimentator » mercoledì 13 febbraio 2013, 19:51

Una domandina: nell'articolo originale (Versione 2B), è detto che il potenziometro funziona, non si usa nella 2A. Ma adesso salta fuori che funziona solo nella nuova versione col PIC diverso.
Chiaritemi questo casino (sì, casino, a questo punto), per favore :wtf: :wtf: :wtf: .
Io ho caricato nel PIC il programma in italiano, che dovrebbe essere 2B e supportare il potenziometro.
Il potenziometro va o no? Vale la pena che rischio di sfondare il mobile per aggiungerlo o non lo monto perchè non funzionerebbe? Nel secondo caso, devo togliere le resistenze R3,R4 e R5 e i condensatori C1, C2 e C6?
Come ho detto, al posto del potenziometro per la velocità  ora ce n'è uno (peraltro di identico valore) per la regolazione del contrasto del mio particolare visore.
Paulus Tergestinus Experimentator

amario
PlasticoDigitale
Messaggi: 393
Iscritto il: sabato 20 novembre 2004, 15:30
Scala: H0
Ho il plastico: Si
La mia centrale digitale.: Nanox_S88 Minimaus Simplemaus Xwl GenLi BoosterCDE Lokmaus2CDE Lokmaus
Località: Valle Seriana
Contatta:

Re: Problemi con la MiniMaus? - Risolti i miei!

#10 Messaggioda amario » mercoledì 13 febbraio 2013, 21:11

E' nella 2A che si diceva funzionasse, ma io sinceramente ho provato e non andava, nella 2B la funzione è stata tolta del tutto :wink:

Avatar utente
experimentator
PlasticoDigitale
Messaggi: 259
Iscritto il: domenica 24 febbraio 2008, 12:21
Scala: N H0
Ho il plastico: Si
La mia centrale digitale.: Roco+Lokmaus2+Minimaus autocostruito+NanoX autocostruita
Località: Trieste

Re: Problemi con la MiniMaus? - Risolti i miei!

#11 Messaggioda experimentator » giovedì 14 febbraio 2013, 20:59

amario ha scritto:E' nella 2A che si diceva funzionasse, ma io sinceramente ho provato e non andava, nella 2B la funzione è stata tolta del tutto :wink:

Ah, dal sito di Paco pareva il contrario. :?
Allora avevo ragione a parlare di "casino"? :roll:
Io le due resistenze e i tre condensatori, oltre al potenziometro, li ho proprio rimossi. O non dovevo farlo (faccio presto a rimetterceli)? EDIT: ce li ho rimessi, so che così andava. Ho tolto solo quelli elettricamente collegati al potenziometro, ovviamente sono quelli ad essere inutili.
Il mobile è piuttosto "ampio", riesco a comandare la tastiera con una mano e tenere il mobile con l'altra, ma se avessi dovuto maneggiare pure il potenziometro, non sarebbero state rare le cadute.
Ho messo anche due "torrette" per applicare in "riposo" una plastica che protegga il visore da urti, non si sa mai.
Come connessioni ho usato le DIN. Domani preparo il filo adattatore (RJ da un lato, DIN dall'altro).
Ho montato sul mobile due DIN in parallelo, così il bus può essere usato mettendo in cascata con cavi DIN/DIN altri dispositivi.
Paulus Tergestinus Experimentator

Avatar utente
experimentator
PlasticoDigitale
Messaggi: 259
Iscritto il: domenica 24 febbraio 2008, 12:21
Scala: N H0
Ho il plastico: Si
La mia centrale digitale.: Roco+Lokmaus2+Minimaus autocostruito+NanoX autocostruita
Località: Trieste

Re: Problemi con la MiniMaus? - Risolti i miei!

#12 Messaggioda experimentator » mercoledì 20 febbraio 2013, 17:48

Per funzionare "a vuoto", la centralina funziona (mi preoccupa un po', perchè col pannello lustro si vede bene, la leggera insellatura nel pannello provocata dalle due sfinestrature di tastiera e visore :? che mi avrebbe obbligato a non mettere il potenziometro della velocità  anche se l'avessi potuto usare), il visore ora ha il contrasto regolabilissimo, la tastiera provoca quel che deve provocare.
E adesso inzia la paura... :wtf: :wtf:
Come decoder accessori ho usato quello di Paco stesso, che per sua stessa ammissione è mutuato da uno del MERG (da loro non più presentato).
Finora sono riuscito a capire che CV 513 serve a dare un numero alle uscite: 1=1,2,3,4; 2=5,6,7,8 e via di 4 in 4. Per le ridotte dimensioni del plastichino, ne andranno due o tre, quattro se con quello piloterò anche un segnale (inutile per una cosa così piccola imbarcarsi in altri progetti). Ma...
Ma per controllare la destra o la sinistra, visto che ogni uscita ne ha due, una che va in positivo quando va a massa l'altra, con MiniMaus come si fa? Prima il numero e poi le frecce < e >, come ho capito, o si deve agire diversamente? :climb:
Anche se sperimento da 30 anni e più (che faccio qualcosa di mia ideazione/elaborazione sono 30 anni esatti ad aprile), se percorro una via già  provata da altri, se ci riesco vorrei sentire cosa ne pensano loro. :wink:
Paulus Tergestinus Experimentator

amario
PlasticoDigitale
Messaggi: 393
Iscritto il: sabato 20 novembre 2004, 15:30
Scala: H0
Ho il plastico: Si
La mia centrale digitale.: Nanox_S88 Minimaus Simplemaus Xwl GenLi BoosterCDE Lokmaus2CDE Lokmaus
Località: Valle Seriana
Contatta:

Re: Problemi con la MiniMaus? - Risolti i miei!

#13 Messaggioda amario » domenica 24 febbraio 2013, 18:48

Non so con il decoder che hai tu perché non ce l'ho a disposizione , ma con altri è come dici tu, prima il numero poi < o >

Avatar utente
experimentator
PlasticoDigitale
Messaggi: 259
Iscritto il: domenica 24 febbraio 2008, 12:21
Scala: N H0
Ho il plastico: Si
La mia centrale digitale.: Roco+Lokmaus2+Minimaus autocostruito+NanoX autocostruita
Località: Trieste

Re: Problemi con la MiniMaus? - Risolti i miei!

#14 Messaggioda experimentator » lunedì 25 febbraio 2013, 23:12

amario ha scritto:Non so con il decoder che hai tu perché non ce l'ho a disposizione , ma con altri è come dici tu, prima il numero poi < o >

Sto costruendone in serie! Ne ho già  pronto uno e domani assemblo un secondo...
Paulus Tergestinus Experimentator

Avatar utente
r302
PlasticoDigitale
Messaggi: 485
Iscritto il: sabato 2 luglio 2005, 19:30
Scala: H0
Ho il plastico: Si
La mia centrale digitale.: JMRI + Kdccx - XnTcp per iBookG4 - Lokmaus2 Simplemaus e iPhone in WiFi
Località: Sicilia
Contatta:

Re: Problemi con la MiniMaus? - Risolti i miei!

#15 Messaggioda r302 » martedì 2 aprile 2013, 1:14

Niente. Oggi ho rimesso mano al mio minimause ma non funza. Prima di rifare il pbc chiedo a chi l'ha fatto e funziona se mi passa una "summa" di tips&tricks per farne uno davvero funzionante.
Insomma, ho seguito le istruzioni fino alle ultime contenute in questo topic, ma buco sempre.
Grazie a chi vorrà  darmi una mano.
r302
centrale Kdccx con il suo booster - interfaccia XnTcp per iBookG4 - palmari Multimaus, Lokmaus2, Simplemaus (in costruzione) e iPhone in WiFi (se riesco a farlo funzionare!) - software JMRI

http://www.aulino.it/aulinodecals/Aulin ... ecals.html


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti