Rocview/Lubuntu - Problema con le librerie wxwidgets

Sezione dedicata alle discussioni riguardanti tutti i software (Windigipet, Railware, Railroad&Co) per PC ingrado di gestire il nostro plastico.

Moderatori: Luca.Rubini, Seba55, peppardo

Messaggio
Autore
antogar
PlasticoDigitale
Messaggi: 509
Iscritto il: venerdì 17 marzo 2006, 16:37
Scala: H0
Ho il plastico: Si
La mia centrale digitale.: Analogico
Località: NA

Rocview/Lubuntu - Problema con le librerie wxwidgets

#1 Messaggioda antogar » sabato 21 gennaio 2017, 12:33

Ciao a tutti :)

sto avendo problemi con RocRail su un vecchio PC con Lubuntu 15.10.
Ho installato la versione rocrail-11851-ubuntu1404-i386.deb (32bit), il server parte tutto ok ma RocView mi restituisce questo errore:

The library used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8 ),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1002,wx containers,compatible with 2.8 ).

dovrei ricompilare le librerie grafiche con la versione ABI 1002 del compilatore.... non ho la più pallida idea di come fare.

qualcuno mi saprebbe aiutare ?

un saluto.
Antonino

antogar
PlasticoDigitale
Messaggi: 509
Iscritto il: venerdì 17 marzo 2006, 16:37
Scala: H0
Ho il plastico: Si
La mia centrale digitale.: Analogico
Località: NA

Re: Rocview/Lubuntu - Problema con le librerie wxwidgets

#2 Messaggioda antogar » mercoledì 25 gennaio 2017, 8:46

Nessuno ha installato Rocrail/Roview su ubuntu? :(

Avatar utente
Buddace
Site Admin
Messaggi: 15467
Età: 41
Iscritto il: lunedì 2 febbraio 2004, 17:25
Scala: H0
Ho il plastico: Si
La mia centrale digitale.: TMWDCC TBX zDCC Lokmaus2 HornbySelect Arnold Intellibox Claudia_CommandStation
Località: Torino
Contatta:

Re: Rocview/Lubuntu - Problema con le librerie wxwidgets

#3 Messaggioda Buddace » mercoledì 25 gennaio 2017, 10:51

Mi spiace ma personalmente non amo linux..
Fondatore e amministratore di DCCWorld

http://www.DCCWorld.com - il sito dedicato interamente ai sistemi di controllo digitale per il modellismo ferroviario.

antogar
PlasticoDigitale
Messaggi: 509
Iscritto il: venerdì 17 marzo 2006, 16:37
Scala: H0
Ho il plastico: Si
La mia centrale digitale.: Analogico
Località: NA

Re: Rocview/Lubuntu - Problema con le librerie wxwidgets

#4 Messaggioda antogar » giovedì 26 gennaio 2017, 0:10

Buddace ha scritto:Mi spiace ma personalmente non amo linux..


Ok, non lo ami... e quindi nessun altro ? :D

antogar
PlasticoDigitale
Messaggi: 509
Iscritto il: venerdì 17 marzo 2006, 16:37
Scala: H0
Ho il plastico: Si
La mia centrale digitale.: Analogico
Località: NA

Rocview/Lubuntu - Problema con le librerie wxwidgets [risolt

#5 Messaggioda antogar » martedì 14 febbraio 2017, 19:30

Anche se il boss non lo ama, sappiate che Rocrail gira senza problemi su un vecchio PC (celeron/1G RAM) con Lubuntu, distribuzione light di Linux.
Alla fino ho risolto con un aggiornamento.

saluti

Thund75
PlasticoDigitale
Messaggi: 149
Età: 44
Iscritto il: domenica 6 dicembre 2009, 6:14
Scala: H0
Ho il plastico: Si
La mia centrale digitale.: Roco Multizentrale. Rocomotion. Multimaus e Pro. Routecontrol.
Località: Brescia
Contatta:

Re: Rocview/Lubuntu - Problema con le librerie wxwidgets

#6 Messaggioda Thund75 » sabato 20 gennaio 2018, 13:44

Io ho installato il tutto su un vecchio pc con lubuntu, perchè uno dei pochi modi di far vedele la multizentrale a Rocrail.
I pacchetti li trovi già compilati, io li ho solo installati.
Non è stato molto difficile, solo un po' di pazienza. Però ho avuto un sacco di problemi con il demone che continua a dare errori e i feedback pur funzionando non venivano gestit.
Alla fine ho cambiato la centrale e sono tornato con windows... e sto incominciando ad usarlo seriamente.
Visitate Il mio canale Youtube
HO, FS,EP: IV-V-VI, DCC


Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti